Musepack Forums

Musepack Forums (https://forum.musepack.net/index.php)
-   MPC for Windows (https://forum.musepack.net/forumdisplay.php?f=8)
-   -   Bug with Unicode on Winamp5 APEv2.0 (https://forum.musepack.net/showthread.php?t=309)

Blacker47 25 November 2006 06:59 pm

Bug with Unicode on Winamp5 APEv2.0
 
If I tag mpc files with APEv2.0 and chars not from default charset in my MS windows playlist of winamp shows only question-chars. File-info in winamp shows unicode as expected.

The same with monkey-Audio files.
Ogg and MP3 with ID3v2.3/4 are visible with all unicode chars in the playlist of winamp.

Don't know, if bug are in winamp or Musepack plugin.

P.S.: Used Plugin: 0.99g

Shy 25 November 2006 08:07 pm

The bug is probably due to the new APEv2 support in Winamp breaking some plugins that already supported it. The Winamp developers are working on a new plugin that will fix that.

Edit: mixed up rg/ape

flocksoft 25 November 2006 08:21 pm

some clarification:

- winamp (main windows) supports unicode characters in filename and title starting from 5.3 version (currently 5.32)
- winamp media library doesn't support unicode
- by default the titles IN PLAYLIST are read from media library (so no unicode support), but this standard behaviour can be switched off in preferences\media library\local media\options tab and disable use library title informations for playlist item formatting

but....

this doesn't affect anyway the actual musepack plugin, because it's old and it's not been compiled with latest winamp sdk (5.25) to support last features (like transcoding, real media library support, 24 bit output, etc.)

currently the winamp dev team is developing a native musepack plugin, so stay tuned

bye ;)


All times are GMT. The time now is 04:07 pm.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.