Musepack Forums

Musepack Forums (
-   MPC for UNIX (
-   -   Still having problems to get mpc to work in amarok (

ilikedirt 14 April 2005 03:14 pm

Still having problems to get mpc to work in amarok

i'm running Ubuntu 5.04 and installed gstreamer, arts and xine with the corresponding amarok-xxx packages.

But - no matter which engine I choose - amarok refuses to add any mpc file to the playlist "Some URLS were not suitable for the playlist"...

Am I missing something? :roll:

Thanks in advance,


xmixahlx 14 April 2005 04:32 pm


what version of gstreamer are you using?

musepack support arrived quite soon, and i believe for hoary that ubuntu froze packages in january or february...


Lefungus 14 April 2005 04:38 pm

Ubuntu's multimedia is castrated by default.
In order to play musepack files, you need to:

-compile and install libmusepack

for gstreamer:
-compile and install gst-musepack

for xine and arts, you may also need to compile/install them again to trigger the libmusepack detection.

ilikedirt 14 April 2005 05:05 pm

Hi, thanks for the advices... I downloaded tarballs of libmusepack, gst-plugins and arts but i fail to install libmusepack...

I extracted libmusepack, switched to the dir and tried following the steps you described in the ubuntu amd 64 topic

configure --prefix=/usr
sudo make install

but bash reports: "command not found" for configure

i tried installing gcc 3.3 through synaptic as this was the best i could think of... :oops:

well, I think I still have to learn a LOT in linux ;)

Lefungus 14 April 2005 05:31 pm

You have to install all the development packages. I don't remember the names though.

ilikedirt 14 April 2005 10:39 pm

Hi again ;)

now I managed compiling libmusepack through

make install

now I try to compile gst-plugins the same way, but ./configure reports that gstreamer wasn't found and that I should specify it's path.. don't know how to do that, though...

I hope I don't bother you too much, but I really can't stand Linux without my MPCs :wink:

xmixahlx 14 April 2005 11:14 pm

i'd suggest installing the packages from debian unstable + rarewares

All times are GMT. The time now is 07:17 am.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2021, vBulletin Solutions Inc.