Musepack Forums

Musepack Forums (
-   MPC for UNIX (
-   -   xmms-musepack dependencies? (

gord 13 December 2005 06:39 pm

xmms-musepack dependencies?
When trying to install the xmms plugin through synaptic (via rarewares), I get this error:

Depends: libgcc1 (>=1:4.0.2) but 1:4.0.1-4ubuntu9 is to be installed
Depends: libstdc++6 (>=4.0.2-4) but 4.0.1-4ubuntu9 is to be installed
Depends: libtag1c2a (>=1.4) but it is not installable
Depends: xmms (>=1.2.10+cvs20050809) but 1.2.10+cvs20050209-2ubuntu2 is to be installed

I checked my repositories and did not see those versions available.

When trying to compile them myself (configure && make), I get an error about not finding a compiler. I'm fairly new to linux, so I'm sure I'm not doing something right. Thanks.

xmixahlx 13 December 2005 08:16 pm

rarewares is built for debian/unstable... so you have a few options:

#1/ upgrade your ubuntu distro

#2/ compile from source (you will need a bunch of dev packages from ubuntu to build yourself)

#3/ otherwise you can see if older packages will work for you here:


gord 13 December 2005 08:26 pm

Thanks - I'll try the old packages and see if that works.

Goweropolis 15 December 2005 08:52 pm

I had this problem this past week as well. I am running Testing with stuff from Rarewares as well. I dist-upgraded and xmms-musepack was removed. A couple of days later (and after updating and dist-upgrading) xmms-musepack worked. Perhaps there was some kind of package transition. I'm not technical enough to know exactly what changed.

xmixahlx 15 December 2005 11:26 pm

xmms-musepack is now in official debian repo's so it may be in testing now.

the debian testing rep could work for ubuntu folks, too...


All times are GMT. The time now is 07:27 am.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2021, vBulletin Solutions Inc.