Musepack Forums

Musepack Forums (
-   General (
-   -   mppenc is mpcenc? (

scottydog90 04 December 2007 08:14 pm

mppenc is mpcenc?
at the risk of being repeatedly slapped about the head..
have downloaded the new sv8 package to start testing and both eac and foobar ask me to tell it where mppenc is and i can't cos its now called mpcenc.
if i rename mppenc to mpcenc it will not encode.
sorry if this is a basic question but have been using musepack for a long time and i never work in the dos arena...i rely totally on windows frontend gui's
(be gentle with me)
cheers for any advice

Antonski 04 December 2007 11:00 pm

It is not important at all what will be the name of the encoder.
I've just tried with EAC (v0.99pb3) and it works with arbitrary file name of the external encoder (EAC -> External Compression).
If you use some older version of EAC, there could be some discrepancy in the command line parameters that the EAC sends to the encoder, though.
In Foobar you probably have to define a new converter (Preferences -> Tools -> Converter -> Add new -> Encoder -> Custom). Then browse to encoder location (again no matter what name does it have) and in the parameter field set for example "--extreme --silent - %d".

scottydog90 05 December 2007 09:45 pm

thanks for your reply.
tried as you say eac and seemed to encode nicely but none of the tracks will play. i get an error dialogue box saying "file uses intensity stereo,not supported anymore! please decode with command line tool."
foobar i've given up on as its gonna taken an hour and a half to do a 3 minute track (encoding at 0.00-0.4)
getting frustrated so may just stick with sv7 unless someone like yourself can help

Antonski 05 December 2007 11:05 pm


Originally Posted by scottydog90 (Post 1725)
thanks for your reply.
tried as you say eac and seemed to encode nicely but none of the tracks will play. i get an error dialogue box saying "file uses intensity stereo,not supported anymore! please decode with command line tool."

It seems that you try to play them with old sv7 plugin for Winamp.
Download the new plugin for sv8 and give a try, it should work.

scottydog90 06 December 2007 08:29 pm

many thanks for your help antonski
eac seems to rip flawlessly (average 20.42x)have put latest winamp plugin in and am listening away as we speak.
i wasn't trying to play the files in winamp before as i don't like winamp (it can't do gapless mix cd's-dispite what people say-theres always a slight hesitation no matter what settings you employ)
i was using quintessential player and that won't touch the files.i suppose i'll have to wait for them to catch up!
i'd also rather use dbpoweramp for cd ripping and at present that don't work either.
seems i'm excitedly jumping the gun.
foobar still don't work for me but then again i don't like it so i'll bin it anyway.
(anything that can't scroll playing song in taskbar just doesn't cut for me)
once again thanks for your help...i'll just have to wait for the other apps to catch up

Antonski 06 December 2007 08:57 pm


Originally Posted by scottydog90 (Post 1732)
many thanks for your help antonski

Hi Scott,

I'm glad that I was able to help you, even with my poor english:).
As of the wider musepack sv8 support, maybe you can write to support staff of your favorite programs and suggest them to upgrade their products?


TheaSiX 02 June 2009 08:27 pm

MPC Encoder 1.30
EAC 0.99

I've been going mad for the last two hours. After a formatting my system I wanted to rip some CDs to MPC again and suddenly I have problems (never happened before!).

Settings I use:

Command line: - --quality 8 --xlevel --artist "%a" --title "%t" --album "%g" --year "%y" --track "%n" --genre "%m" %s
Add ID3 tag - unchecked
Use external program for compression - checked
Parameter passing scheme - User Defined Encoder
Encoder - 32bit
Use Offset Correction - unchecked

The problem is that I got the message "File uses Intensity Stereo, which is not supported anymore. I'm using SV8 package and Winamp I've spent two hours looking for some answers but no results so far. Tried different settings, different command lines but nothing seems to be working. Any help would be very much appreciated as I can't rip my CDs to anything other than MPC !

Antonski 03 June 2009 01:03 pm

First, you should not use --xlevel anymore,

D:\Util\MusePack\sv8>mpcenc --xlevel "test.wav"
MPC Encoder 1.30.0 --stable-- (C) 1999-2009 Buschmann/Klemm/Piecha/MDT
Built Feb 26 2009 20:33:36

Xlevel coding not needed anymore, --xlevel ignored.

Second, which plugin do you use? If you try to play the files with the Nullsoft plugin, you'll definitely have troubles. It just doesn't support SV8.

TheaSiX 03 June 2009 10:24 pm

The thing is everything worked fine before formatting. I had SV8 plugin and Winamp 5.54 and I had no problems.. now suddenly Winamp doesn't support it? Why's that? I had to switch back to SV7 to be able to rip&listen to..

Wish MPC was known much better so people would support it finally..

Antonski 05 June 2009 03:24 pm

Could you send me some of those files? I'm just curious, I checked with WA 5.551 and everything is working fine. So, some file could be corrupted. If your doubts are about WA, you should make a clean reinstall, I've fixed some times very strange problems by reinstalling. Or just switch to another player. Foobar suports Musepack SV8 since the very beginning. If you need a complete music library organizer, I would suggest you MusicBee, perfect rapid development/bugfixing and no problems with SV8.

All times are GMT. The time now is 06:52 pm.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2021, vBulletin Solutions Inc.