Musepack Forums

Musepack Forums (
-   MPC for UNIX (
-   -   Getting SV8 support in MPD working (

njak 30 December 2011 03:55 pm

Getting SV8 support in MPD working
I'm not able to play back sv8 properly in mpd.

In mpd I recently tried to playback an sv8 file, and it did work (except seek bar, but I don't really care :)).
So I batch converted all my library to sv8 (mpc2sv8). In mpd the library finally looked great... until I realized that the playback is not working for all files:confused:. some files play well, and some other have "clicks" and "plops" in them.

I tried compiling mpd with latest musepack libs again and again, and no good result until now. I even tried to compile ports from gentoo right into my arch linux instal as they provided some info about sv8 support!

I recently filled a bug in mpd site ( but the guy there said it compiles fine, so it's ok for him.
I'm left with my files which can be played only by foobar, or doing a mpcdec to wav, and then aplay for instance... but not in the player I most often use.

As I'm not a developer, I don't get why this does not work. I'm looking for help so that someone can spend some time find why it does not work and point the mpd devs on to the right point!
Looking at their source, they have indeed changed their code to build against latest mpc libs, but yet, it compiles, plays back but not right. I need someone more skilled to see why this is "almost" working!

So as I found no topic related to that, I was hoping a new thread could bring some progress on that.

Anyone of you had a better experience, or have any clue on this ?

Antonski 03 January 2012 11:03 am

So, these files are played fine in Foobar, but not in mpd (honestly, I haven't heard about it so far).
Unfortunately, I am not experienced with compiling, but could you upload some of these "faulty" files to, say Mediafire and PM me the links?
I'm curious if I will have troubles with some of my players.

r2d 03 January 2012 12:46 pm

I tried mpd on my linux distro (kubuntu) and sv8 files seems to play as expected. The mpd version I have is 0.16.2.
Can you post a file that doesn't play well ?
If you play the file multiple times, do the clicks always append the same way ?

njak 03 January 2012 04:26 pm

Hi Antonski and r2d, thank you for helping!

There is some good news: I've been through the process once again yesterday (I don't count the times I did that).
Actually I got it working this time I think!:)

I'm not sure yet I understood what happened, but I guess that
- usually when building the musepack tools, the install part was not full: After digging around, I realized that was not installed.
Under the ArchLinux distro, you first build a package upon compilation, and then install it over the older one (like in most distros...).
It results (I guess) that I was running mpd (0.16.6) built to support the newest musepack library, but actually linked to the previous one.
I copied manually the to /usr/lib and checked with ldd the linking

Is that possible that my previous attempts were actually linked with the older lib, and yet it was running (a weird fashion, but with no error)?
More over in my previous compilation attempts, I manually copied the lib as well (or I manually erased the older lib before installing). After all maybe it's another problem.

Anyway after doing so, I was not finished yet: all the files were playing a constant ugly noise on top of them (but different from the usual one which was on specific parts of the track, always the same) .

I then played around with the mpd configuration, and noticed that the replaygain was on, so I assumed that the level used to correct the volume was way too loud for some reason. After unselecting the replaygain, the files which were not playing correctly were sounding nice again.

I'm going to test more thoroughly with other files, as it did work on some on not on others before my latest compilation attempt.

Maybe the problem is elsewhere, as I found in ArchLinux, in the "community" repository a build script which I used this time only. But I don't think they used a patch in it, though I didn't check (what I'm sure is that they forgot the file).

So if my guesses are right, there are only two minor problems:
- building musepack tools is sometimes done by packagers without actually installing the new lib (they only install the tools, mpcenc etc.) - or I just did something wrong which is also a possibility which must not be excluded !
- replaygain may need some attention, but I can live without it.
All my files were created in sv7, then converted to sv8. I just don't know if replaygain was calculated on them.

I'll post you in a couple of hours a file which was playing badly if you're interested, just to see if this was only local to my setup or if it happens elsewhere.

Anyway thanks for your help

njak 03 January 2012 08:59 pm

here is a link to a file which was not playing well on my previous install
and a version converted to mp3

it starts normally (a kind of rythm with the bass guitar), and then when at the percussion hits (don't known which instrument it is, looks like a rythm box), the sound becomes weird on this precise sound...

Antonski 19 January 2012 10:18 pm

Hi njak,

Sorry for may late answer, I've just realized that I've forgotten to reply.
I didn't find anything weird playing the file on Foobar, MusicBee and VLC, all on Windows.
The file didn't have RG (about -6 dB), but there was no difference with and without RG (except the volume, of course).
I hope you can find a way to fix your problem with mpd.


njak 20 January 2012 09:18 am

Hi Antonski
Thank you this is very helpful.
I finally got sv8 working, and the last point which was not working was that the sound was distorded when activating replay gain. Now that you tell me that the replay gain was not present in the file, I guess this explains the behavior.

Thanks again!

All times are GMT. The time now is 08:29 am.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2021, vBulletin Solutions Inc.