Musepack Forums

Musepack Forums (https://forum.musepack.net/index.php)
-   MPC for UNIX (https://forum.musepack.net/forumdisplay.php?f=9)
-   -   Musepack-tools and Ubuntu 7.04 (https://forum.musepack.net/showthread.php?t=362)

Timo425 10 May 2007 06:29 am

Musepack-tools and Ubuntu 7.04
 
Hello,

I am trying to decode some .mpc files to .flac or whatever else lossless (or to .wav itself), I installed a nautilus script for that, but it tells me I don't have musepack-tools codec for it.
Well then, I searched it in Synaptic, no. Then 'sudo aptitude search musepack-tools' didn't find (even if I searched musepack I found unnecessary packs). Then I found some links for the source, they were broken.. Then I searched in google, some German pages, but I don't understand German and there seemed to be no necessary file.
I didn't find it in this forum here, too..
Help the noobie! :rolleyes:

xmixahlx 10 May 2007 05:08 pm

you want the program "mppdec"

you can either grab the source, compile & install or use rarewares/debian and install "musepack-decoder"

follow the link in my sig

Timo425 10 May 2007 06:16 pm

http://www.debianquestions.com/ln-ar...pic.php?t=1420 is broken link or something? Anyway I discovered pin apt, great possibility to block annoying upgrades. :)

So, I added RareWares Debian GNU/Linux Repository (the link of course) to my sources.list, but: 'sudo apt-get install musepack-decoder' and musepack-decoder isn't found.
:confused:
Also:
Quote:

W: GPG error: http://mirror.home-dn.net sarge Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: GPG error: http://www.debian-multimedia.org experimental Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 07DC563D1F41B907
W: You may want to run apt-get update to correct these problems


P.S - I haved used linux for some weeks only, so.. :-P

xmixahlx 10 May 2007 08:00 pm

you need to update your sources first:
# apt-get update && apt-get install musepack-decoder

Timo425 10 May 2007 08:04 pm

Quote:

Originally Posted by xmixahlx (Post 1554)
you need to update your sources first:
# apt-get update && apt-get install musepack-decoder

E: Couldn't find package musepack-decoder

I copied your command...

:neutral:

Those GPG errors mentioned above are from 'sudo apt-get update'

andrea 29 July 2007 09:26 pm

mpc123 --waw decodes .mpc to .wav
 
hi,
I was having the same problem: I found mpc123 on the standard ubuntu repositories, which worked perfectly for listening, but then lame encoded the files like if they were .wav, thus producing only noise! Then I realized on mpc123 man page that a line like

mpc123 --wav file.wav file.mpc

does the job (note: it is "- - w a v": on some fonts double dashes are hardly recognized)

bye, Andrea


All times are GMT. The time now is 12:52 am.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.