Musepack Forums

Musepack Forums (https://forum.musepack.net/index.php)
-   MPC for Windows (https://forum.musepack.net/forumdisplay.php?f=8)
-   -   Winamp plugin for sv8 (https://forum.musepack.net/showthread.php?t=422)

Antonski 07 November 2007 02:16 pm

Winamp plugin for sv8
 
Hi,

When the input WA plugin with sv8 support is expected to be available? Even some beta version?
I believe that lack of such plugin is one of the main reasons for low popularity of the new format.
I, for example, don't feel comfortable with foobar2000, I believe many others too.

~

Antonski 07 November 2007 11:16 pm

Sorry, I saw the other threads about that subject a bit later.
It seems that Nullsoft is not interested in that plugin too much.
It is a pity.

Seed 12 November 2007 07:28 pm

The source code has been on our SVN for a long time. Anyone who wants WinAmp support for SV8 beta can compile it and test.

Antonski 20 November 2007 12:13 am

Good. However I was not able to compile it by neither MSVC6 (as expected) nor MSVC8. I don't have enough space left on my drive C to try MSVC7.
Could somebody help with the compiling?
~

r2d 21 November 2007 09:21 am

I can help ...

First you need a taglib port for windows :
https://code.launchpad.net/~taglib-d...lib/taglib.ext
(you needs bazaar http://bazaar-vcs.org/Download and cmake http://www.cmake.org/HTML/Download.html )

The last builds I did used taglib with static link (you need to make changes in the taglib cmake files) , but the default taglib config is dynamic link. You should start with the dll.

Once you have built taglib and installed it, try compiling winamp-musepack and post the ouput you get. Probably you will have to change the project files to use the taglib dll.

I'll be very happy if you manage to compile it, as I need to use a virtual machine to do it.

Nicolas

r2d 23 November 2007 06:16 pm

done it, untested :
http://r2d.musepack.net/files/musepack_bin_20071123.zip

Antonski 25 November 2007 10:11 pm

Hi Nikolas,

Thank you for your efforts.
Unfortunately, the plugin crashed winamp either with sv7 or sv8 files :(
I tried on Winamp 2.95, soon I plan to try Winamp5.5, but I believe the result will be the same.

Shy 25 November 2007 11:28 pm

It's fine with Winamp 5.

Antonski 26 November 2007 02:06 pm

Correct, it works with Winamp55. Too bad, because recently I switched back to v2.xx.
The new v5.5 has the bad habit to stop working after some days :(
Anyway, thank you very much for the great job!

~

Antonski 26 November 2007 11:01 pm

I should correct myself. After uninstall and clean install of Winamp 2.95 the musepack plugin is working fine.
Thanks again Nikolas!
~

Antonski 05 December 2007 11:41 am

Hi Nick,

I've identified the reason for crashing Winamp with mpc files. Obviously it happened when I use a dsp plugin called SpeakerSimulator (by Vladimir Kopjov). It never happened neither with the older mpc plugin nor with other format plugins.
Could it be that the reason is similar to the one that caused problems with pipe decoding? If this is the case, is it easy to fix?
Thanks

Seed 06 December 2007 03:47 am

The latest version is here

Antonski 06 December 2007 01:36 pm

Quote:

Originally Posted by Seed (Post 1727)
The latest version is here

Actually, in this last release from 01/12/2007 only the mpcdec was updated.
The WA plugin included in the pack is the originally compiled one (dated 23/12/2007) that caused Winamp crash.
~

r2d 09 December 2007 11:19 am

Quote:

Originally Posted by Antonski (Post 1723)
Hi Nick,

I've identified the reason for crashing Winamp with mpc files. Obviously it happened when I use a dsp plugin called SpeakerSimulator (by Vladimir Kopjov).

Does the crash append with all the dsp plugins, or just this one ?

Antonski 09 December 2007 01:49 pm

Quote:

Originally Posted by r2d (Post 1734)
Does the crash append with all the dsp plugins, or just this one ?

Well, I generally don't use dsp plugins, only this one when I use speakers.
After I doscovered the problem I've tried some other plugins that claim to do the same job, but since I was not satisfied with the quality, I refused to use them, even they don't crash the Winamp.
However, I don't exclude the possibility that some other plugin interacting with in_mpc would crash WA. This would be a problem once the new format gains a popularity.
I thought that there could be some problem with stdio because in description of the mentioned plugin one can read that it could operate directly with the raw PCM stream coming from the output of in_CDReader plugin.
Of course I might be wrong, I don't know anything about the Winamp plugins design.
I would write to the author of the dsp plugin, however it seems that this project has been discontinued and the home page has disappeared.

Do you have an idea what could be the problem?

Regards
Tony

Antonski 09 December 2007 03:10 pm

Hi again,

I've just discovered that transcoding from mpc also does not work, either with WA 5.5 or 5.51.
I don't know whether this is due to the same problem, though.
~

Edit: BTW, I don't use Winamp for transcoding and if this feature breaks the compatibility with Winamp 2.xx, I would really prefer to have a working plugin for both 5.xx and 2.xx without transcoding capabilities :)

Rabbit 23 December 2007 04:04 pm

ReplayGain doesn't work, visualisation updates once per second. With Winamp 5.51.

fbslim 27 January 2008 11:23 am

Quote:

Originally Posted by Seed (Post 1727)
The latest version is here

in_mpc.dll

I'm sorry guys, but, toooooo many bugs to use it.....:(

Seed 27 January 2008 10:33 pm

And if the bugs are to be fixed, we should know what they are :)

fbslim 28 January 2008 09:39 pm

Quote:

Originally Posted by Seed (Post 1778)
And if the bugs are to be fixed, we should know what they are :)

1. bitrate shows fixed and did not change, while playback.
2. sometimes do not show tag info just from fisrt click, sometimes frize while shows. but, today, for example - no such problems at all. anyway, i can’t remember that i seen such bug on any old plugin for SV7 version.
3. I don’t like the new Musepack icon in tags! Please leave the old one, from SV7 pugin, and the whole old style of showing tag to!!! ;)))

That’s all for now… :)

PS
Tested on 5.51


All times are GMT. The time now is 08:27 pm.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.