Musepack Forums

Musepack Forums (https://forum.musepack.net/index.php)
-   MPC for UNIX (https://forum.musepack.net/forumdisplay.php?f=9)
-   -   How to install? (https://forum.musepack.net/showthread.php?t=47)

Dro77naR 12 September 2004 10:29 pm

How to install?
 
Hi, I'm totally lame in linux and I don't know how to install musepack plugin for xmms.
I have two files: libmusepack-1.0.1.tar.bz2 and xmms-musepack-1.1.alpha7.tar.bz2, I extracted them and I don't know what should I do with extracted files... Please, help me.

The_Paranoid 12 September 2004 10:49 pm

after extracting become root by typing su.
First go to the libmusepack dir and do a make install.
Then to the xmms-musepack dir and do a make install.
Now the plugin should be installed ;)

Dro77naR 12 September 2004 11:06 pm

That's not so easy becaus after command make install I have response: make: command not found :(

Ganymed 13 September 2004 09:03 am

Quote:

That's not so easy becaus after command make install I have response: make: command not found :(
I think you didn't unpack the archives or didn't change to the libmusepack directory.

bunzip2 libmusepack-1.0.1.tar.bz2
tar -xvf libmusepack-1.0.1.tar
cd libmusepack-1.0.1
su
make install

Do the same commands for the xmms plugin archive.

The_Paranoid 13 September 2004 09:52 am

Mmmh, i he wasn't in the right dir or didn't unpack something like make: *** No rule to make target `install'. Stop. should appear.
But command not found seems like a pretty borked up system ...

Check if you have make installed by typing /usr/bin/make ... if still command is not found you have a big problem :(

Dro77naR 13 September 2004 03:53 pm

I don't have this directory, but I don't think it's a big problem. I just have to install somethingg... but what? :)

Dro77naR 14 September 2004 04:54 pm

OK, I've installed 'make' and i've tried to install xmms plugin... and I had an error again. This time I saw this:
Code:


source/xmms-musepack-1.1-alpha8 # make install

g++ -Wall -fPIC -DPIC -O2 -march=i686 -pipe -DPOSIX -D_REENTRANT -DVERSION="1.1-alpha8" -I/usr/include/musepack `pkg-config --cflags glib-2.0` `xmms-config --cflags` `gtk-config --cflags` -pthread -c libmpc.cpp

/bin/sh: line 1: pkg-config: command not found

/bin/sh: line 1: xmms-config: command not found

/bin/sh: line 1: gtk-config: command not found

/bin/sh: line 1: g++: command not found

make: *** [libmpc.o] Błąd 127

Erm, 'Błąd' means Error :)

and what now?

ak 14 September 2004 09:31 pm

Install pkg-config xmms gtk and gcc as well :wink:

Dro77naR 14 September 2004 10:33 pm

I have installed what is needed... but still I had problems. And now I resolve them... I found rpm which working!!!

Thanks to all who tried to help me :)

And I'm sorry for my English :)

aitherios 06 October 2004 02:35 am

i had this problem...
i even tried the rarewares debian repository... installed but xmms didnt seem to work with mpc...
anyway, if someone could help; by the way, what rmp? where can i find it?

g++ -Wall -fPIC -DPIC -O2 -march=i686 -pipe -DPOSIX -D_REENTRANT -DVERSION="1.1-alpha10" -I/usr/include/musepack `pkg-config --cflags glib-2.0` `xmms-config --cflags` `gtk-config --cflags` -pthread -c libmpc.cpp
/bin/sh: xmms-config: command not found
libmpc.cpp:8:25: xmms/plugin.h: No such file or directory
libmpc.cpp:9:29: xmms/configfile.h: No such file or directory
libmpc.cpp:10:30: xmms/titlestring.h: No such file or directory
libmpc.cpp:11:23: xmms/util.h: No such file or directory
libmpc.cpp:41: error: syntax error before `*' token
[...]
edited: big error list cut

fuffy 06 October 2004 10:54 am

because you are building a xmms plugin you need the devel package with the headers, too.

Code:

apt-get install xmms-dev

Aliaric 11 November 2004 06:49 pm

How i must install last version which in .zip format.?

P.S. It's nice codec. I like it. ^^

Shy 12 November 2004 10:49 pm

Same instructions as above, only you need unzip.

Aliaric 13 November 2004 03:55 pm

I read 3 times instructions above, but there are no make file or configure file in .zip archieve. :? There is only mpdec

Shy 13 November 2004 11:25 pm

There is a Makefile, between idtag.cpp and mpc_dec.cpp, and as The Paranoid said you need to extract the zip to a folder and in the folder type "make install".

Aliaric 15 November 2004 04:10 pm

thanks :idea:


All times are GMT. The time now is 04:14 pm.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.