Musepack Forums

Musepack Forums (https://forum.musepack.net/index.php)
-   MPC for UNIX (https://forum.musepack.net/forumdisplay.php?f=9)
-   -   Broken files under Linux? (https://forum.musepack.net/showthread.php?t=350)

Blacker47 22 March 2007 02:52 pm

Broken files under Linux?
 
After encoding album A, all works fine (1.15v alpha). Then I copy it to my test-linux (Etch) and try to play it with Amarok 1 of 19 file are not playable with it. XMMS seems to play it, but the end of file are cuted (maybe on other files too). mpc123 seems to play all fine. MD5 and mpcscan gives no problem. The files are APEv3 taged.

So my first idea was a bug in the encoder. I updated to the last stable and try album B. I got 3 corrupt files there.

I'm not sure that versions of decoder are used under Debian Linux. Maybe it is libmpcdec3 1.2.2-1.

I hope you can say me, there the problem is. I have to know the files are broken or not. If needed I maybe could send the files privately.

xmixahlx 22 March 2007 06:08 pm

so...

are you using rarewares packages?

how are you determining they are corrupt?

i am not aware of bugs you are describing and i use debian unstable...

if mpc123 (using libmpcdec) plays them fine then my first direction would be to ask the Amarok guys.


later

Blacker47 22 March 2007 07:47 pm

Quote:

Originally Posted by xmixahlx (Post 1514)
so...
are you using rarewares packages?

What the thing?

I don't hear any music on this files. Only from time to time some sounds from soundcard.

Firstly I tested it in a VM. Now I tested it directly on a PC and it is the same bug. And with the same files.

Software: Amarok 1.4.4 BuildDate: Feb 18 2007

xmixahlx 22 March 2007 11:06 pm

yeah, i just tested some 1.15 and 1.16 files in amarok 1.4.4 and everything is fine.

you could check to make sure that id3v2 tags aren't present.

are you sure it isn't a general sound problem?

how did you create the musepack files? how else are you playing them back on windows?

Blacker47 22 March 2007 11:31 pm

Actualy i donn't know how to check for tags but I don't add some of id3 tags.

Only some files are played corrupted. The other files are played withoud problems.

I create files under Windows (XP.SP2 32 single core) with MPC Batch Encoder and last with mpcenc 1.16. Used profile: "--braindead". For taging I optional used Mp3tag. In Winamp5 with last plugin there is no problem. I tested some other players under Linux and they seems to work.

I find more people with the same problem - http://bugs.kde.org/show_bug.cgi?id=140244

Bug could be in the engine xine, amarok uses.

r2d 27 March 2007 03:38 pm

Quote:

Originally Posted by Blacker47 (Post 1513)
After encoding album A, all works fine (1.15v alpha). Then I copy it to my test-linux (Etch) and try to play it with Amarok 1 of 19 file are not playable with it.

I also had issues with Amarok playing mpc, but don't know more as I don't use it (And I'm using mandriva 2006).

Quote:

Originally Posted by Blacker47 (Post 1513)
XMMS seems to play it, but the end of file are cuted (maybe on other files too).

Yes, this is a known bug (at least to me and Lefungus). It is a xmms-musepack plugin bug that I have corrected in my branche.

I think your encoded files are OK, maybe you can build the xmms-musepack plugin from the svn (this branche : http://trac.musepack.net/trac/browse...k/branches/r2d, using this libmpcdec : http://trac.musepack.net/trac/browse...c/branches/r2d) or ask nicely xmixahlx to make a package for you.

xmixahlx 27 March 2007 05:09 pm

sv8 is already packaged:

on debian unstable (with rarewares repository):
apt-get install xmms-musepack-sv8

...will grab libmpcdec6 and xmms-musepack-sv8 from r2d's sv8 branches and you're all set. this will not replace existing libmpcdec (1.2.2, 1.2.4, 1.2.5) libraries, either.


later

celafon 28 July 2007 10:12 am

I got the same strange error. Only very few files though, but it requires me to use something else for playing them...

I recommend we post more confirmations in the bugzilla, so the bug will be fixed by Amarok devs.

Bartek


All times are GMT. The time now is 12:14 am.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.