Musepack Forums

Musepack Forums (
-   General (
-   -   Problem with MONOGRAM Direct Show filters (

negotio 20 August 2012 08:32 pm

Problem with MONOGRAM Direct Show filters
Hi everybody,
I want to switch from v7 to the new v8. Unfortunately the MONOGRAM Direct Show filters are not working with my Windows Media Player. Foobar works fine, but this is not the solution I expect. The v7 Radlight filters worked well for v7 files on my system. I used from the main site and installed the filter successfully in an Admin shell. Unfortunately Windows Media Player just throws a error that it can not play the file, because the type or the codec is not supported.
Can anybody help me with this issue ?

System: Windows Vista Business 32bit

Antonski 20 August 2012 10:37 pm

Have you tried Media Player Classic with MONOGRAM's filters? Joust for test?
I don't use WMP,, but MPC is working fine. It even works with chapters!
(If I remember well, these filters had to be enabled in Options)

negotio 23 August 2012 10:14 pm

I tried MPC and added the MONOGRAMM filters (Decoder and Splitter) manually in the Options menu, but MPC just throws "Can not render file". I think there is a Windows problem with that filter. Any further support is appreciated.:)

Antonski 24 August 2012 08:36 pm

Maybe the best you can do is to contact Igor (the developer) and ask him for hints.

I've used on a number of machines with no problems, but only with XP.


It maybe worth having a look on the page below, it's not about musepack, but may give you some directions...

negotio 25 August 2012 02:43 pm

Thanks for your support. I made some progress on this issue. I used the mentioned Graphedit and found out, that v7 have a render path in Graphedit. I suggest, that they use the Radlight filter. V8 files can not even be rendered with Graphedit. So I think v8 files do not have the correct "marker" to be opened with the MONOGRAMM filters.

Antonski 25 August 2012 09:18 pm

Hi negotio,

Don't get me wrong, but I have to ask, did you register both filters (dec and dmx) by regsvr32?

You can check whether they are registered with key /i :


C:\>regsvr32 /i
C:\>regsvr32 /i

If they ate not, you have to do it in command line (as Administrator), just run the following command in the folder when these both files are unpacked:



There is also a prerequisite for these filters to work, you must have installed Visual Studio 2005 SP1 Redistributable Package.

If all this doesn't help, the next that comes into my mind is that you might use 64-bit version of WMP, but these filters are32-bit, so this would be a no-go case.

BTW, may I ask you, is there some particular reason to use WMP for playback?
If there is no such, I would suggest you some (good) working replacements :)
First, Foobar2000 is maybe the most reliable player, with good Musepack support among the others. It has a bit severe interface, though.
Then, MusicBee (my favorite), with perfect Musepack support (including chapters), nice interface and plenty of features but not bloated, fast and working fine with huge audio libraries. Weekly updated, with the fastest bug fighting among all SW products I've ever seen.
Then, VLC also supports musepack (since v1.6), although no chapters yet.

There are some others, of course, but I stopped searching after I discovered MusicBee.

Antonski 26 August 2012 03:19 pm

Well, please ignore my previous post. I've just re-read your first post and answered myself to most of the questions.
The only feasible suggestion was to check whether you have installed VS runtime before installing the new filters.
I don't know whether the old Radlight filters can prevent the proper registration of the new Monogram filters. You can maybe try to remove the older filters if nothing else will help.
They would not be needed anyway, because Monogram filters support both sv7 & sv8.

All times are GMT. The time now is 07:53 pm.

Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2021, vBulletin Solutions Inc.