View Single Post
Old 18 November 2004, 04:44 pm   #1
mingotta
Member
 
Join Date: Nov 2004
Posts: 5
Default No package 'glib-2.0' found

I'm trying to install the mpc plugin on debian linux.
As I make install, an error says glib-2.0 is missing.
How do I go about installing it?
apt-cache search glib brings about nothing relevant.

Code:
root@0[xmms-musepack-1.1-alpha10]# make install

g++ -Wall -fPIC -DPIC -O2 -march=i686 -pipe -DPOSIX -D_REENTRANT -DVERSION="1.1-alpha10" -I/usr/include/musepack `pkg-config --cflags glib-2.0` `xmms-config --cflags` `gtk-config --cflags` -pthread -c libmpc.cpp

Package glib-2.0 was not found in the pkg-config search path.

Perhaps you should add the directory containing `glib-2.0.pc'

to the PKG_CONFIG_PATH environment variable

No package 'glib-2.0' found

libmpc.cpp: In function `char* convertUTF8toLocale(char*)':

libmpc.cpp:119: error: `g_locale_from_utf8' undeclared (first use this

   function)

libmpc.cpp:119: error: (Each undeclared identifier is reported only once for

   each function it appears in.)

libmpc.cpp: In function `void convertLE32to16(MPC_SAMPLE_FORMAT*, char*,

   unsigned int)':

libmpc.cpp:131: warning: unused variable `int float_scale'

libmpc.cpp: At top level:

tags.h:22: warning: `const char*GenreList[148]' defined but not used

make: *** [libmpc.o] Error 1
mingotta is offline   Reply With Quote