Thread: libmpcdec 1.2.5
View Single Post
Old 11 February 2007, 07:54 pm   #1
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default libmpcdec 1.2.5

Bug-fix release
1.2.3 and 1.2.4 break binary compatibility with apps compiled under 1.2.2. Those may crash, corrupt & explode.

To get back a sane system, you need to:

- Remove libmpcdec 1.2.3/1.2.4. The hardcore way is 'sudo rm -i /usr/lib/libmpcdec.*'. Don't do this if you don't know what it does.
Some people have those libs inside /usr/local/lib
- Install libmpcdec-1.2.2 again, usually the binary provided by your distribution is fine. This one will be used for compatibility with apps you can't recompile.
- Install libmpcdec-1.2.5. It won't conflict with 1.2.2 though. To get back the improved seeking speed, you need to recompile your app using libmpcdec. Most of the time, you will only need to recompile either xmms-plugin or the gstreamer-musepack plugin.
Lefungus is offline   Reply With Quote