View Single Post
Old 23 November 2006, 11:26 am   #1
Join Date: Nov 2006
Posts: 3
Default [xmms-musepack] decodeStream is unable to open http://...


I got a problem playing mpc files via http.
Background: I wrote a web application to have access to my music at work. Everything works flawlessly
- with Windows (i.e. WinAmp)
- with Linux (i.e. Amarok)

but when xmms with musepack-plugin is told to play an mpc file via .m3u file, it says:
[xmms-musepack] decodeStream is unable to open
Local playback of mpc files works fine with xmms.

What I've tried so far:
Setting mimetype in apache (audio/x-musepack mpc) - no difference
Downgrading to older versions
Googling, googling, googling

An example m3u looks like this:
#EXTINF:145, example song
My System:
Debian testing
xmms 1:1.2.10+20061101-1 (older versions don't work as well)
xmms-musepack 1.2.1-0rarewares1 (older versions don't work as well)

I just don't get it - every other player i tried works, but as i want to use xmms-crossfader amarok is no alternative for me.

Does anybody have an idea?

Thnx, jeremia
jeremia is offline   Reply With Quote