View Single Post
Old 30 December 2011, 03:55 pm   #1
Join Date: Dec 2011
Posts: 4
Unhappy Getting SV8 support in MPD working

I'm not able to play back sv8 properly in mpd.

In mpd I recently tried to playback an sv8 file, and it did work (except seek bar, but I don't really care ).
So I batch converted all my library to sv8 (mpc2sv8). In mpd the library finally looked great... until I realized that the playback is not working for all files. some files play well, and some other have "clicks" and "plops" in them.

I tried compiling mpd with latest musepack libs again and again, and no good result until now. I even tried to compile ports from gentoo right into my arch linux instal as they provided some info about sv8 support!

I recently filled a bug in mpd site ( but the guy there said it compiles fine, so it's ok for him.
I'm left with my files which can be played only by foobar, or doing a mpcdec to wav, and then aplay for instance... but not in the player I most often use.

As I'm not a developer, I don't get why this does not work. I'm looking for help so that someone can spend some time find why it does not work and point the mpd devs on to the right point!
Looking at their source, they have indeed changed their code to build against latest mpc libs, but yet, it compiles, plays back but not right. I need someone more skilled to see why this is "almost" working!

So as I found no topic related to that, I was hoping a new thread could bring some progress on that.

Anyone of you had a better experience, or have any clue on this ?
njak is offline   Reply With Quote