Musepack Forums  

Go Back   Musepack Forums > Main > Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 10 May 2005, 12:00 am   #1
Sebastian Andersson
Member
 
Join Date: May 2005
Posts: 3
Default MSVC linker error

Hello!

I am getting this error when trying to build libmpcdec;

Code:
LINK : fatal error LNK1561: entry point must be defined
Anyone else experiencing this?

Regards,
Sebastian Andersson
Sebastian Andersson is offline   Reply With Quote
Old 10 May 2005, 10:37 pm   #2
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

Which version of Visual Studio ?
What are you compiling ? libmpcdec in release/debug mode ?
It work fine for me on msvc6 and Seed was able to compile it without link errors on .net 2003.
We did spot an error though, when you try to compile the sample app in debug mode. I fixed this and will update the svn when it'll be synchronized again. However, sample workspace compile an optionnal example app, so you don't need it to make use of the library.
Lefungus is offline   Reply With Quote
Old 11 May 2005, 01:28 pm   #3
Sebastian Andersson
Member
 
Join Date: May 2005
Posts: 3
Default

I am compiling libmpcdec in Release mode using Visual Studio 6 along with Service Pack 5 and processor pack.
Sebastian Andersson is offline   Reply With Quote
Old 11 May 2005, 07:18 pm   #4
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

Please pm/send me the build log, which should be named libmpcdec.plg.
Lefungus is offline   Reply With Quote
Old 11 May 2005, 09:45 pm   #5
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

You have this:
Creating command line "link.exe @E:\DOCUME~1\SEBAST~1\LOKALA~1\Temp\RSP1690.tmp"
while it should be this:
Creating command line "link.exe -lib @E:\DOCUME~1\SEBAST~1\LOKALA~1\Temp\RSP1690.tmp"

For some reason I'm not aware of, your msvc doesn't compile the lib as a lib. I also use msvc6 + sp5 + processor pack, so I can only guess it's due to some bug or weird config in your msvc installation
Lefungus is offline   Reply With Quote
Old 12 May 2005, 12:33 am   #6
Sebastian Andersson
Member
 
Join Date: May 2005
Posts: 3
Default

Oh. Thanks for pointing it out! I will have a look at it.
Sebastian Andersson is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
--extreme setting with CDEX -> error Apocalypse Dude General 2 31 May 2005 09:00 pm
compile error mppdec dkraft MPC for UNIX 3 28 February 2005 06:49 pm
ERROR: Sampling frequency of 88.2 kHz is not supported! robertuss General 1 06 February 2005 07:20 pm
Error emerging musepack-tools on Gentoo giambuca MPC for UNIX 1 30 November 2004 09:44 am
gentoo media-sound/muse media-sound/musepack-tools error puck MPC for UNIX 2 14 August 2004 09:05 pm


All times are GMT. The time now is 01:43 am.


Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2017, vBulletin Solutions Inc.