Musepack Forums  

Go Back   Musepack Forums > Main > Development

Reply
 
Thread Tools Search this Thread Display Modes
Old 08 December 2006, 01:42 pm   #1
Zenitram
Member
 
Join Date: Apr 2006
Posts: 5
Default ./configure missing in libmpcdec 1.2.4

The last version of limpcdec forgot ./configure file.
Edit : ./configure is missing in 1.2.3 too, but is present in 1.2.2
There is ./autogen.sh, but this is not "pretty" for automatic installations without installing autotools.

And if I do ./autogen.sh, I have this error :
Putting files in AC_CONFIG_AUX_DIR, `config'.
include/Makefile.am:5: invalid variable `nobase_include_HEADERS'
__________________
Want to know all about your media files? http://mediainfo.sourceforge.net

Last edited by Zenitram; 08 December 2006 at 02:01 pm.
Zenitram is offline   Reply With Quote
Old 08 December 2006, 02:46 pm   #2
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

Configure has been removed on purpose since it can be regenerated automatically with autogen.sh.

However, autogen.sh *should* work. Maybe we need to fix something. Can I ask you your autotools version, and can you check which tool produce this error by calling autotools manually ?
Lefungus is offline   Reply With Quote
Old 09 December 2006, 02:10 pm   #3
Zenitram
Member
 
Join Date: Apr 2006
Posts: 5
Default

I note for ./configure, even if I don't agree : autotools are not often installed, so some people won't easily do "./configure;make" as they does for other softwares. For example, I had to install it for you only ;-)

For autogen.sh :
Zenitram@s01:~$ wget http://files.musepack.net/source/lib...-1.2.4.tar.bz2
15:00:36 (78.57 KB/s) - `libmpcdec-1.2.4.tar.bz2' saved [43735/43735]
Zenitram@s01:~$ bunzip2 libmpcdec-1.2.4.tar.bz2
Zenitram@s01:~$ tar xf libmpcdec-1.2.4.tar
Zenitram@s01:~$ cd libmpcdec-1.2.4/
Zenitram@s01:~/libmpcdec-1.2.4$ ls
AUTHORS autogen.sh ChangeLog configure.ac COPYING docs include INSTALL Makefile.am README src win32
Zenitram@s01:~/libmpcdec-1.2.4$ mkdir config
Zenitram@s01:~/libmpcdec-1.2.4$ libtoolize --copy --force
You should add the contents of `/usr/share/aclocal/libtool.m4' to `aclocal.m4'.
Putting files in AC_CONFIG_AUX_DIR, `config'.
Zenitram@s01:~/libmpcdec-1.2.4$ aclocal
Zenitram@s01:~/libmpcdec-1.2.4$ autoheader
Zenitram@s01:~/libmpcdec-1.2.4$ automake --gnu --add-missing --copy
automake: configure.ac: installing `config/install-sh'
automake: configure.ac: installing `config/mkinstalldirs'
automake: configure.ac: installing `config/missing'
include/Makefile.am:5: invalid variable `nobase_include_HEADERS'
Zenitram@s01:~/libmpcdec-1.2.4$

automake version : 1.4-p6-11
Note: when checking for automake version, I noticed that automake 1.9 was available too with my distrib (Ubuntu 6.10, by default apt-get install automake installs v1.4).
With automake 1.9, script is OK.
__________________
Want to know all about your media files? http://mediainfo.sourceforge.net
Zenitram is offline   Reply With Quote
Old 09 December 2006, 04:20 pm   #4
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

Ok, you have a point and I'll add back configure script into the distributed package so people won't have to guess which autotools package to install. However, svn won't have it as it is unnecessary there.
1.2.4 will be updated soon.
Lefungus is offline   Reply With Quote
Old 09 December 2006, 04:24 pm   #5
Zenitram
Member
 
Join Date: Apr 2006
Posts: 5
Default

Good news, thanks!
(and I agree with you : SVN needn't it, this is a "release specific" file)
__________________
Want to know all about your media files? http://mediainfo.sourceforge.net
Zenitram is offline   Reply With Quote
Old 09 December 2006, 07:04 pm   #6
Shy
Admin
 
Shy's Avatar
 
Join Date: Jul 2004
Posts: 369
Default

Updated on the server. Redownload.
Shy is offline   Reply With Quote
Old 10 December 2006, 03:53 am   #7
xmixahlx
Musepack developer
 
xmixahlx's Avatar
 
Join Date: Nov 2004
Location: seattle, washington usa
Posts: 111
Send a message via ICQ to xmixahlx
Default

i think it is unnecessary.

any developer will have a current autotools version installed.


but, whatever...
__________________
-xmixahlx, the one they call "mike"
http://xmixahlx.com -|- http://rarewares.org
xmixahlx is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
libmpcdec 1.2.5 Lefungus Development 0 11 February 2007 07:54 pm
libmpcdec not working when linked with mplayer since 1.2.3 Nicholi Development 4 27 January 2007 12:44 pm


All times are GMT. The time now is 06:52 pm.


Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2017, vBulletin Solutions Inc.