Musepack Forums  

Go Back   Musepack Forums > Main > MPC for UNIX

 
 
Thread Tools Search this Thread Display Modes
Prev Previous Post   Next Post Next
Old 17 July 2005, 02:59 pm   #1
mala
Member
 
Join Date: Jul 2005
Location: Germany
Posts: 2
Default problem with xmms-musepack

Hi, I have a problem to get xmms-musepack-1.2RC1 to run on my G3 running debian sarge. I've compiled libmpcdec and xmms-musepack with the same version of the C/C++ compiler as xmms/taglib are compiled with (xmms 1.2.10, taglib 1.3.1). Whenever I try to load a musepack file into xmms, it segfaults (all libraries/shared objects are found). I have done a backtrace in gdb:

GNU gdb 6.3-debian
Copyright 2004 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "powerpc-linux"...(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".

(gdb) r 01.flac.mpc
Starting program: /usr/bin/xmms 01.flac.mpc
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 23968)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 32769 (LWP 23969)]
[New Thread 16386 (LWP 23970)]
[New Thread 32771 (LWP 23971)]
Message: device: default

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 16386 (LWP 23970)]
0x0ee9953c in TagLib::String::String () from /usr/lib/libtag.so.1
(gdb) bt
#0 0x0ee9953c in TagLib::String::String () from /usr/lib/libtag.so.1
#1 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#2 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#3 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#4 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#5 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#6 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#7 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#8 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#9 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#10 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#11 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#12 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
#13 0x0ee99528 in TagLib::String::String () from /usr/lib/libtag.so.1
Previous frame inner to this frame (corrupt stack?)
(gdb) q
The program is running. Exit anyway? (y or n) y

Any ideas?

Many thanks in advance.

mala
mala is offline   Reply With Quote
 

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install musepack on Fedora Core 4 with xmms? someuser77 MPC for UNIX 1 09 December 2005 06:03 pm
Problem with xmms :( c_olin MPC for UNIX 5 19 July 2005 01:28 pm
Xmms / Beep plugins for musepack Lefungus MPC for UNIX 22 25 February 2005 05:41 pm
Does xmms' equalizer works with musepack plugin? qrt666 MPC for UNIX 4 27 September 2004 05:42 pm
Using XMMS with musepack superk MPC for UNIX 3 07 September 2004 05:54 pm


All times are GMT. The time now is 03:13 am.


Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2020, vBulletin Solutions Inc.