Musepack Forums  

Go Back   Musepack Forums > Main > MPC for UNIX

Reply
 
Thread Tools Search this Thread Display Modes
Old 02 July 2005, 04:53 am   #1
ugly
Member
 
Join Date: Jul 2005
Posts: 3
Default xmms-musepack 1.2 RC1 not displaying characters with umlauts

When I add characters that use an umlaut or other unusual character (unicode?) to the APETAG of a MPC, the full field isn't displayed in the playlist. It is displayed in MP3s, so it seems to be a xmms-musepack specific problem. The tags were manually set using the xmms-musepack apetag editor.

I'm using XMMS 1.2.10+cvs20050209-2 (Debian sarge) with xmms-musepack plugin 1.2 RC1.

A screenshot of the problem showing the full tag as output by the 'apetag' utility, and the "cut off" tag in the XMMS playlist: here (edit: replaced with link for users with limited connection)
ugly is offline   Reply With Quote
Old 02 July 2005, 11:39 am   #2
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

XMMS doesn't support unicode. One thing you can try is enabling "unicode" support in the font preferences. See if it improve things.
If you want perfect unicode support, switch to Beep-Media-Player or any other player.

Anyway, xmms should convert your characters properly, so maybe something is still borked in the plugin. I'll check that.
Lefungus is offline   Reply With Quote
Old 02 July 2005, 06:24 pm   #3
ugly
Member
 
Join Date: Jul 2005
Posts: 3
Default

Quote:
Originally Posted by Lefungus
XMMS doesn't support unicode. One thing you can try is enabling "unicode" support in the font preferences. See if it improve things.
If you want perfect unicode support, switch to Beep-Media-Player or any other player.

Anyway, xmms should convert your characters properly, so maybe something is still borked in the plugin. I'll check that.
I don't seem to have a unicode option in my Fonts section. Do you mean the "Use fontsets (Enable for multi-byte charset support" option? I enabled that, but the problem is the same.

I still think it's a plugin specific issue, as the below screenshot shows that MP3s (see the "Vintersorg" track) with tags containing umlauts do not have the problem.

ugly is offline   Reply With Quote
Old 03 July 2005, 08:31 pm   #4
Lefungus
Procrastinator
 
Lefungus's Avatar
 
Join Date: Jul 2004
Posts: 131
Default

This file isn't properly tagged. Did you use apetag ? If yes, it doesn't properly support UTF-8. You should contact his maintainer.
Xmms break on it, as BMP which is unicode. Foobar2000 (on windows) also report invalid characters.
If I hexedit the file to use the proper UTF-8 value, your tag is displayed fine under xmms.
I recommend Ex-Falso as a good unix tagger.

Lefungus is offline   Reply With Quote
Old 03 July 2005, 11:19 pm   #5
ugly
Member
 
Join Date: Jul 2005
Posts: 3
Default

Hmm, you're right. I had tagged the files using XMMS's built in editor, but I had pasted the foreign characters from the gucharmap utility (an obvious rip off of Windows' character map). I rewrote the tags using characters pasted from the 'iso_8859_15' man page instead, and now the tags are displayed properly in XMMS. Apetag doesn't display them properly, however, for the reason you mentioned, I would imagine.

Thanks,

ugly
ugly is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
how to install musepack on Fedora Core 4 with xmms? someuser77 MPC for UNIX 1 09 December 2005 06:03 pm
Using XMMS with musepack superk MPC for UNIX 3 07 September 2004 05:54 pm


All times are GMT. The time now is 04:45 pm.


Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.