Musepack Forums  

Go Back   Musepack Forums > Main > MPC for UNIX

Reply
 
Thread Tools Search this Thread Display Modes
Old 22 August 2010, 12:55 pm   #1
Sean
Member
 
Join Date: Aug 2010
Posts: 1
Default Problem trying to install muse on Ubuntu 10.04

Hi, I have been trying to compile K3b 2.0.0 from the source files on Ubuntu 10.04 and have managed to install all the dependencies that the programme needs apart from muse
Here is the output of cmake

sean@sean-desktop:~/Downloads/k3b-2.0.0/build$ sudo cmake ..
-- Found Qt-Version 4.6.2 (using /usr/bin/qmake)
-- Found X11: /usr/lib/libX11.so
-- Phonon Version: 4.3.1
-- Found KDE 4.4 include dir: /usr/include
-- Found KDE 4.4 library dir: /usr/lib
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4
-- Found taglib: -L/usr/lib -ltag
-- Taglib found: -L/usr/lib -ltag
-- Found FFMPEG: /usr/local/lib/libavcodec.a;/usr/local/lib/libavformat.a;/usr/local/lib/libavutil.a /usr/local/include
-- Could NOT find MUSE (missing: MUSE_INCLUDE_DIR MUSE_LIBRARIES MPC_HEADER_FILE)
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- Found OggVorbis: /usr/lib/libogg.so;/usr/lib/libvorbis.so;/usr/lib/libvorbisfile.so;/usr/lib/libvorbisenc.so
-- DCOP stuff was remove into kde4, convert it to dbus please.kde4_add_dcop_skels macro doesn't exist now. We keep it just to remember to port to dbus
-- found new ffmpegcodecpath

-----------------------------------------------------------------------------
-- The following dependencies were found.
-----------------------------------------------------------------------------
* kdelibs - The toolkit K3b uses to build
* libDVDRead - Libdvdread provides a simple foundation for reading DVD video disks.
* Taglib - Read and write tags in audio files
* Samplerate - Audio sampling rate conversion.
* Musicbrainz - Provide information about the CD, about the artist or about related information
* KCddb - KCddb is used to retrieve audio CD meta data from the internet.
* FFmpeg - Needed for the K3b FFmpeg decoder plugin which can decode virtually all audio types.
* Flac - Needed for the Flac audio decoder plugin.
* Flac++ - Needed for the Flac audio decoder plugin.
* Mad mp3 - Needed for the mp3 audio decoder plugin.
* Sndfile - Needed for the libsndfile audio decoder plugin.
* Lame mp3 encoder - Needed for the lame mpf encoder encoder plugin.
* Ogg Vorbis - Needed for the K3b Ogg Vorbis decoder and encoder plugins.

-----------------------------------------------------------------------------
-- The following OPTIONAL dependencies could NOT be found.
-----------------------------------------------------------------------------
* Muse <http://www.musepack.net/>
Needed for the Musepack audio decoder plugin

-----------------------------------------------------------------------------

-- Configuring done
-- Generating done
-- Build files have been written to: /home/sean/Downloads/k3b-2.0.0/build


Please could someone give me a simple walk through on how to go about installing the Musepack audio decoder plugin.
I downloaded musepack_linux_2009_02_28 but didn't understand the README instructions

-- Musepack binaries --
All binaries exept mpcenc need libmpcdec to run, and mpcgain needs libmpcdec and libreplaygain.
So copy the content of the lib directory in one of your lib directory (ex /usr/local/lib) or add it to the LD_LIBRARY_PATH environment variable before running a program.


I am new to linux and know how to install a programe from source using
./configure
make
sudo make install


but that's about all I can do at the moment. Can you also have a look at the cmake output and let me know if you think that it all looks OK
I would really appreciate any help that you guys can offer me

Thanks
Sean
Sean is offline   Reply With Quote
Old 25 August 2010, 06:47 pm   #2
r2d
Musepack developer
 
Join Date: Sep 2006
Location: Villeurbanne - France
Posts: 36
Default

You should install the packets libmpcdec3 and libmpcdec-dev. The source code you downloaded is the code for the new sv8 library which is probably not supported by k3b.
Also k3b 2.0.0 is available from Ubuntu repositories, so it may not be necessary to compile it.
r2d is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT. The time now is 07:43 am.


Powered by vBulletin® Version 3.8.11 Beta 2
Copyright ©2000 - 2019, vBulletin Solutions Inc.